Problem z odpaleniem strony na Internet Explorer

Witajcie ponownie. Od jakiegoś czasu mam zgłaszane problemy o nie możności odpalenia strony w przeglądarce Internet Explorer. Rzeczywiście istnieje ten problem dla tej przeglądarki. IE wczytuję stronę, żeby zaraz po załadowaniu wyrzucić informację " program internet explorer nie może otworzyć miejsca internetowego … operacja przerwana. " po zatwierdzeniu tej informacji klawiszem OK, wyświetla się strona " Nie można wyświetlić strony " . Mogę jakoś wpłynąć na tą sytuację, żeby strona sprawnie działała pod tą przeglądarką ? Pozdro.

Sposób wyświetlania odpowiedzi

Wybierz preferowany sposób wyświetlania odpowiedzi i kliknij "Zachowaj ustawienia", by wprowadzić zmiany.

hej

Pomóżcie rozwiązać ten problem, bo to jest ważne w prawidłowej konfiguracji drupala.

Portret użytkownika Coincidence

Prawidłowo skonfigurowany

Prawidłowo skonfigurowany Drupal wyświetla się bezproblemowo w IE. Daj jakąś szansę i podaj chociaż link do problematycznej strony.

strona

www.cyryl.przester.com jak mógłby mi ktoś pomóc przy okazji w tym żeby panel logowania zrobić na tym niebieskim tle gdzie jest logo strony, byłbym bardzo wdzięczny. Dzięki i pozdrawiam. Cy­ryl.

Ja tam bym się explorerem

Ja tam bym się explorerem wogule nie przejmował, nikt już tego badziewia nie używa, a jeśli używa, to ma problem, nie sposób pisać stron specjalnie dla jakiejś przestarzałej i dziadoskiej przeglądarki. Nawet istnieje taki moduł drupala, który blokuje przed dostępem z explorera o pięknej nazwie IE Destroyer ;-) :

http://www.filbar.org/…/iedestroyer

zastanawiam się, czy by go u siebie nie zainstalować nawet :-P

-- Szaman

http://unitra.eu.org

Dzięki Szaman za

Dzięki Szaman za odpowiedź, ale nie jest to rozwiązanie mojego problemu. Pozdrawiam.

Też miałem taki problem

Też miałem taki problem na mojej stronie http://www.jurgowski.pl. Działo sie to na stronach z filmami z Youtube.

Załatwiłem to w ten sposób: http://www.eastwoodzhao.com/…issue-fixed/ :-)

Portret użytkownika palik

ooo stary, wiszę ci

moderator

ooo stary, wiszę ci wirtualne piwo, od razu pomogło :)

javasript

w moim przypadku była to wina javascript. Kod który operuje na jeszcze nie załadowanych elementach trzeba wykonać na końcu strony. Przed tagiem . Jak to zrobić to już inna historia.

Ja dalej tego nie

Ja dalej tego nie rozwikłałem. Jak ktoś wie jak to rozwiązać , proszę o wzięcie udziału w dyskusji.

Rozwiązanie problemu

IE zachowuje się tak po chamsku gdy wykonywane pliki javascript np swfobject wykonują się przed załadowaniem całej strony a korzystają zw zmiennych, które mogły się jeszcze nie załadować.

Rozwiązniem tego problemu jest np wykorzystanie biblioteki jquery i komendy:

$(document).re­ady(function() {
so.write(„flashcon­tent“); });

Przyklad podaje dla prawidłowego zaimplementowanie swfobjecta.